Vulnerabilidad en 7-Zip se aprovecharía del software de seguridad

Vulnerabilidad en 7-Zip se aprovecharía del software de seguridad

La herramienta de compresión para Windows permitiría la ejecución de código en software que utiliza sus funciones.

Las vulnerabilidades en el software están a la orden del día, pues ahora la víctima es nada menos que la famosa herramienta de compresión de código abierto para Windows. 7-Zip no sólo es un cliente de compresión, sino que presta sus funciones mediante librerías para que otros programas las utilicen.

Entre ellos se encuentran otros programas de compresión, como PeaZip, pero también software de seguridad, como soluciones antimalware que se ejecutan con derechos de administrador, usualmente para el análisis de archivos comprimidos, por lo que estarían expuestos a una vulnerabilidad descubierta en 7-Zip.

Dicha vulnerabilidad se encuentra en el código que maneja el formato UDF, extensión por defecto para contenido mutimedia DVD y otros formatos de disco óptico, y permite la ejecución de código con los mismos permisos de funcionamiento que tiene el programa afectado, de acuerdo con la compañía de seguridad Talos (vía gHacks).

El éxito de la explotación dependerá del proceso principal en el que se ejecuta el código. Para evitar afecciones, se insta a los usuarios actualizar a la versión 16.0 de 7-Zip que ha puesto fin a la vulnerabilidad. Por su parte, los responsables de programas que utilizan sus funciones deben usar las librerías de la versión más reciente.

Opinar es gratis, como siempre. No olviden seguirnos y comentar en Facebook.