Descubren una vulnerabilidad crítica que afecta al navegador Opera

Descubren una vulnerabilidad crítica que afecta al navegador Opera

por

Se recomienda no utilizar las últimas versiones del navegador hasta que se libere una actualización.

El investigador de seguridad de origen francés Jordi Chancel descubrió una vulnerabilidad crítica que afecta a las últimas versiones del navegador Opera, por medio de la cual un atacante podría ejecutar código arbitrario de forma remota.

El investigador publicó su descubrimiento en su blog el pasado 7 de enero, lo que fue suficiente para que la compañía VUPEN Security anunciara que sus investigadores habían logrado desarrollar un exploit que se aprovecha de la vulnerabilidad, ejecutando código de forma remota en el computador que utiliza el navegador noruego.

En concreto la vulnerabilidad sería causado por un error de truncado de enteros al interior del módulo “opera.dll”, en momentos en que este último maneja el elemento HTML “select” conteniendo una gran cantidad de elementos hijos.

Por el lado de Opera Software han reconocido la existencia de la vulnerabilidad, detallando que esta se encuentra presente en las versiones 11 y 10.63 de Opera (tanto para Windows 7 como para XP), por lo que recomiendan a los usuarios no hacer uso de ellas hasta que no se encuentre una solución al problema.

Link: Critical Opera Security Flaw Found (eSecurityPlanet)